What’s Vulnerable › Vulnerabilities
CVE-2023-0120: Incorrect Authorization in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue has been discovered in GitLab affecting all versions starting from 10.0 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. Due to improper permission validation it was possible to edit labels description by an unauthorised user.
Affected products
- GitLab: from 10.0.0 before 16.1.5; from 16.2 before 16.2.5; 16.3.0 — fixed in 16.1.5, 16.2.5
How to fix
Upgrade to a fixed version: GitLab 16.1.5, 16.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/387531
- https://hackerone.com/reports/1818425
- https://gitlab.com/gitlab-org/gitlab/-/issues/387531
- https://hackerone.com/reports/1818425
Get alerted when CVE-2023-0120 or the next vulnerability affects your stack