What’s Vulnerable › Vulnerabilities
CVE-2023-0143: Send PDF for Contact Form 7 < 0.9.9.2 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Send PDF for Contact Form 7 WordPress plugin before 0.9.9.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Send PDF for Contact Form 7: before 0.9.9.2 — fixed in 0.9.9.2
How to fix
Upgrade to a fixed version: Send PDF for Contact Form 7 0.9.9.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c4cd3d98-9678-49cb-9d1a-551ef8a810b9
- https://wpscan.com/vulnerability/c4cd3d98-9678-49cb-9d1a-551ef8a810b9
Get alerted when CVE-2023-0143 or the next vulnerability affects your stack