What’s Vulnerable › Vulnerabilities
CVE-2023-0157: All-In-One Security (AIOS) < 5.1.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 32.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The All-In-One Security (AIOS) WordPress plugin before 5.1.5 does not escape the content of log files before outputting it to the plugin admin page, allowing an authorized user (admin+) to plant bogus log files containing malicious JavaScript code that will be executed in the context of any administrator visiting this page.
Affected products
- All-In-One Security (AIOS): before 5.1.5 — fixed in 5.1.5
How to fix
Upgrade to a fixed version: All-In-One Security (AIOS) 5.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8248b550-6485-4108-a701-8446ffa35f06
- https://wpscan.com/vulnerability/8248b550-6485-4108-a701-8446ffa35f06
Get alerted when CVE-2023-0157 or the next vulnerability affects your stack