What’s Vulnerable › Vulnerabilities
CVE-2023-0159: Extensive VC Addons for WPBakery page builder < 1.9.1 - Unauthenticated RCE
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Extensive VC Addons for WPBakery page builder WordPress plugin before 1.9.1 does not validate a parameter passed to the php extract function when loading templates, allowing an unauthenticated attacker to override the template path to read arbitrary files from the hosts file system. This may be escalated to RCE using PHP filter chains.
Affected products
- Extensive VC Addons for WPBakery page builder: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: Extensive VC Addons for WPBakery page builder 1.9.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/239ea870-66e5-4754-952e-74d4dd60b809
- https://wpscan.com/vulnerability/239ea870-66e5-4754-952e-74d4dd60b809
Get alerted when CVE-2023-0159 or the next vulnerability affects your stack