What’s Vulnerable › Vulnerabilities
CVE-2023-0178: Annual Archive < 1.6.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Annual Archive WordPress plugin before 1.6.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Twinpictures Annual Archive: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Twinpictures Annual Archive 1.6.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cc308e15-7937-4d41-809d-74f8c13bee23
- https://wpscan.com/vulnerability/cc308e15-7937-4d41-809d-74f8c13bee23
Get alerted when CVE-2023-0178 or the next vulnerability affects your stack