What’s Vulnerable › Vulnerabilities
CVE-2023-0231: ShopLentor < 2.5.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The ShopLentor WordPress plugin before 2.5.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/533c19d5-219c-4389-a8bf-8b3a35b33b20
- https://wpscan.com/vulnerability/533c19d5-219c-4389-a8bf-8b3a35b33b20
Get alerted when CVE-2023-0231 or the next vulnerability affects your stack