What’s Vulnerable › Vulnerabilities
CVE-2023-0252: Contextual Related Posts < 3.3.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Contextual Related Posts WordPress plugin before 3.3.1 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- ajay Contextual Related Posts: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: ajay Contextual Related Posts 3.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5754a4fd-1adf-47aa-976f-3b28750058c2
- https://wpscan.com/vulnerability/5754a4fd-1adf-47aa-976f-3b28750058c2
Get alerted when CVE-2023-0252 or the next vulnerability affects your stack