What’s Vulnerable › Vulnerabilities
CVE-2023-0264
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-287
Description
A flaw was found in Keycloaks OpenID Connect user authentication, which may incorrectly authenticate requests. An authenticated attacker who could obtain information from a user request within the same realm could use that data to impersonate the victim and generate new session tokens. This issue could impact confidentiality, integrity, and availability.
Affected products
- Keycloak: before 18.0.6 — fixed in 18.0.6
- Red Hat OpenShift Container Platform 4.18: 4.9, 4.10
- RedHat Openshift Container Platform For Ibm Linuxone: 4.9, 4.10
- RedHat Openshift Container Platform Ibm Z Systems: 4.9, 4.10
- Red Hat Single Sign-On: before 7.6.2 — fixed in 7.6.2
How to fix
Upgrade to a fixed version: Keycloak 18.0.6; Red Hat Single Sign-On 7.6.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-0264
- https://access.redhat.com/security/cve/CVE-2023-0264
Get alerted when CVE-2023-0264 or the next vulnerability affects your stack