What’s Vulnerable › Vulnerabilities
CVE-2023-0266: Linux Kernel Use-After-Free Vulnerability
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-03-30
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-416
Description
A use after free vulnerability exists in the ALSA PCM package in the Linux Kernel. SNDRV_CTL_IOCTL_ELEM_{READ|WRITE}32 is missing locks that can be used in a use-after-free that can result in a priviledge escalation to gain ring0 access from the system user. We recommend upgrading past commit 56b88b50565cd8b946a2d00b0c83927b7ebb055e
Affected products
- Debian Linux: 10.0
- Linux kernel: from 4.14 before 4.14.303; from 4.15 before 4.19.270; from 4.20 before 5.4.229; from 5.5 before 5.10.163; from 5.11 before 5.15.88; from 5.16 before 6.1.6 — fixed in 4.14.303, 4.19.270, 5.10.163, 5.15.88, 5.4.229, 6.1.6
How to fix
Upgrade to a fixed version: Linux kernel 4.14.303, 4.19.270, 5.10.163, 5.15.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/tree/queue-5.10/alsa-pcm-move-rwsem-lock-inside-snd_ctl_elem_read-to-prevent-uaf.patch?id=72783cf35e6c55bca84c4bb7b776c58152856fd4
- https://github.com/torvalds/linux/commit/56b88b50565cd8b946a2d00b0c83927b7ebb055e
- https://github.com/torvalds/linux/commit/becf9e5d553c2389d857a3c178ce80fdb34a02e1
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/tree/queue-5.10/alsa-pcm-move-rwsem-lock-inside-snd_ctl_elem_read-to-prevent-uaf.patch?id=72783cf35e6c55bca84c4bb7b776c58152856fd4
- https://github.com/torvalds/linux/commit/56b88b50565cd8b946a2d00b0c83927b7ebb055e
- https://github.com/torvalds/linux/commit/becf9e5d553c2389d857a3c178ce80fdb34a02e1
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-0266
Get alerted when CVE-2023-0266 or the next vulnerability affects your stack