What’s Vulnerable › Vulnerabilities
CVE-2023-0268: Mega Addons For WPBakery Page Builder < 4.3.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-08 · updated 2026-06-17
Description
The Mega Addons For WPBakery Page Builder WordPress plugin before 4.3.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Topdigitaltrends Mega Addons For WPBakery Page Builder (WordPress plugin): before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: Topdigitaltrends Mega Addons For WPBakery Page Builder (WordPress plugin) 4.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/99389641-ad1e-45c1-a42f-2a010ee22d76
- https://wpscan.com/vulnerability/99389641-ad1e-45c1-a42f-2a010ee22d76
Get alerted when CVE-2023-0268 or the next vulnerability affects your stack