What’s Vulnerable › Vulnerabilities
CVE-2023-0271: WP Font Awesome < 1.7.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The WP Font Awesome WordPress plugin before 1.7.9 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedded, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- zayedbaloch WP Font Awesome: before 1.7.9 — fixed in 1.7.9
How to fix
Upgrade to a fixed version: zayedbaloch WP Font Awesome 1.7.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fd7aaf06-4be7-48d6-83a1-cd5cd6c3d9c2
- https://wpscan.com/vulnerability/fd7aaf06-4be7-48d6-83a1-cd5cd6c3d9c2
Get alerted when CVE-2023-0271 or the next vulnerability affects your stack