What’s Vulnerable › Vulnerabilities
CVE-2023-0274: URL Params < 2.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The URL Params WordPress plugin before 2.5 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- URL Params: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: URL Params 2.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4f6197b6-6d4c-4986-b54c-453b17e94812
- https://wpscan.com/vulnerability/4f6197b6-6d4c-4986-b54c-453b17e94812
Get alerted when CVE-2023-0274 or the next vulnerability affects your stack