What’s Vulnerable › Vulnerabilities
CVE-2023-0278: GeoDirectory < 2.2.24 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-27 · updated 2026-06-17
Description
The GeoDirectory WordPress plugin before 2.2.24 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Affected products
- Wpgeodirectory Geodirectory: before 2.2.24 — fixed in 2.2.24
How to fix
Upgrade to a fixed version: Wpgeodirectory Geodirectory 2.2.24. Check the vendor advisory for mitigations.
References
- https://bulletin.iese.de/post/geodirectory_2-2-21
- https://wpscan.com/vulnerability/98deb84e-01ca-4b70-a8f8-0a226daa85a6
- https://bulletin.iese.de/post/geodirectory_2-2-21
- https://wpscan.com/vulnerability/98deb84e-01ca-4b70-a8f8-0a226daa85a6
Get alerted when CVE-2023-0278 or the next vulnerability affects your stack