What’s Vulnerable › Vulnerabilities
CVE-2023-0284: Improper validation of LDAP user IDs
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation of LDAP user IDs in Tribe29 Checkmk allows attackers that can control LDAP user IDs to manipulate files on the server. Checkmk <= 2.1.0p19, Checkmk <= 2.0.0p32, and all versions of Checkmk 1.6.0 (EOL) are affected.
Affected products
- Checkmk GmbH Checkmk: 2.0.0, 2.0.0-b1, 2.0.0-b2, 2.0.0-b3, 2.0.0-b4, 2.0.0-b5 (+64)
- Tribe29 Checkmk: from 1.6.0 before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Tribe29 Checkmk 2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-0284 or the next vulnerability affects your stack