What’s Vulnerable › Vulnerabilities
CVE-2023-0288: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-13 · updated 2026-09-24
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1189.
Affected products
- Apple macOS: before 13.3 — fixed in 13.3
- Fedoraproject Fedora: 36
- Neovim: through 0.8.3
- vim/vim: before 9.0.1189 — fixed in 9.0.1189
How to fix
Upgrade to a fixed version: Apple macOS 13.3; vim/vim 9.0.1189. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/232bdaaca98c34a99ffadf27bf6ee08be6cc8f6a
- https://huntr.dev/bounties/550a0852-9be0-4abe-906c-f803b34e41d3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYC22GGZ6QA66HLNLHCTAJU265TT3O33/
- https://support.apple.com/kb/HT213670
- http://seclists.org/fulldisclosure/2023/Mar/17
- https://github.com/vim/vim/commit/232bdaaca98c34a99ffadf27bf6ee08be6cc8f6a
- https://huntr.dev/bounties/550a0852-9be0-4abe-906c-f803b34e41d3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYC22GGZ6QA66HLNLHCTAJU265TT3O33/
- https://support.apple.com/kb/HT213670
Get alerted when CVE-2023-0288 or the next vulnerability affects your stack