What’s Vulnerable › Vulnerabilities
CVE-2023-0298: Incorrect Authorization in firefly-iii/firefly-iii
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-14 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
Affected products
- firefly-iii/firefly-iii: before 5.8.0 — fixed in 5.8.0
How to fix
Upgrade to a fixed version: firefly-iii/firefly-iii 5.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/firefly-iii/firefly-iii/commit/db0500dcf0d4f1990fc7a377ef0d56c3884fcaa4
- https://huntr.dev/bounties/9689052c-c1d7-4aae-aa08-346c9b6e04ed
- https://github.com/firefly-iii/firefly-iii/commit/db0500dcf0d4f1990fc7a377ef0d56c3884fcaa4
- https://huntr.dev/bounties/9689052c-c1d7-4aae-aa08-346c9b6e04ed
Get alerted when CVE-2023-0298 or the next vulnerability affects your stack