What’s Vulnerable › Vulnerabilities
CVE-2023-0328: WPCode < 2.0.7 - Contributor+ WPCode Library Auth Key Update/Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-863
Description
The WPCode WordPress plugin before 2.0.7 does not have adequate privilege checks in place for several AJAX actions, only checking the nonce. This may lead to allowing any authenticated user who can edit posts to call the endpoints related to WPCode Library authentication (such as update and delete the auth key).
Affected products
- WPCode: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: WPCode 2.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3c4318a9-a3c5-409b-a52e-edd8583c3c43
- https://wpscan.com/vulnerability/3c4318a9-a3c5-409b-a52e-edd8583c3c43
Get alerted when CVE-2023-0328 or the next vulnerability affects your stack