What’s Vulnerable › Vulnerabilities
CVE-2023-0329: Elementor Website Builder < 3.12.2 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
Description
The Elementor Website Builder WordPress plugin before 3.12.2 does not properly sanitize and escape the Replace URL parameter in the Tools module before using it in a SQL statement, leading to a SQL injection exploitable by users with the Administrator role.
Affected products
- Elementor Website Builder: before 3.12.2 — fixed in 3.12.2
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.12.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/175639/Elementor-Website-Builder-SQL-Injection.html
- https://wpscan.com/vulnerability/a875836d-77f4-4306-b275-2b60efff1493
- http://packetstormsecurity.com/files/175639/Elementor-Website-Builder-SQL-Injection.html
- https://wpscan.com/vulnerability/a875836d-77f4-4306-b275-2b60efff1493
Get alerted when CVE-2023-0329 or the next vulnerability affects your stack