What’s Vulnerable › Vulnerabilities
CVE-2023-0360: Location Weather < 1.3.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Location Weather WordPress plugin before 1.3.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- ShapedPlugin LLC Location Weather: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: ShapedPlugin LLC Location Weather 1.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ba653457-415f-4ab3-a792-42640b59302b
- https://wpscan.com/vulnerability/ba653457-415f-4ab3-a792-42640b59302b
Get alerted when CVE-2023-0360 or the next vulnerability affects your stack