What’s Vulnerable › Vulnerabilities
CVE-2023-0363: Scheduled Announcements Widget < 1.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Scheduled Announcements Widget WordPress plugin before 1.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Scheduled Announcements Widget: before 1.0 — fixed in 1.0
How to fix
Upgrade to a fixed version: Scheduled Announcements Widget 1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6d332a47-e96c-455b-9e8f-db6dbb59b518
- https://wpscan.com/vulnerability/6d332a47-e96c-455b-9e8f-db6dbb59b518
Get alerted when CVE-2023-0363 or the next vulnerability affects your stack