What’s Vulnerable › Vulnerabilities
CVE-2023-0371: EmbedSocial < 1.1.28 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The EmbedSocial WordPress plugin before 1.1.28 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- EmbedSocial: before 1.1.28 — fixed in 1.1.28
How to fix
Upgrade to a fixed version: EmbedSocial 1.1.28. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b6381cd-fa31-4cc7-8b42-063a4c545577
- https://wpscan.com/vulnerability/0b6381cd-fa31-4cc7-8b42-063a4c545577
Get alerted when CVE-2023-0371 or the next vulnerability affects your stack