What’s Vulnerable › Vulnerabilities
CVE-2023-0372: EmbedStories < 0.7.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The EmbedStories WordPress plugin before 0.7.5 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- EmbedStories: before 0.7.5 — fixed in 0.7.5
How to fix
Upgrade to a fixed version: EmbedStories 0.7.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9cf90ad8-4aa4-466c-a33e-4f2706815765
- https://wpscan.com/vulnerability/9cf90ad8-4aa4-466c-a33e-4f2706815765
Get alerted when CVE-2023-0372 or the next vulnerability affects your stack