What’s Vulnerable › Vulnerabilities
CVE-2023-0374: W4 Post List < 2.4.6 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The W4 Post List WordPress plugin before 2.4.6 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- W4 Post List: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: W4 Post List 2.4.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ddb10f2e-73b8-444c-90b2-5c84cdf6de5c
- https://wpscan.com/vulnerability/ddb10f2e-73b8-444c-90b2-5c84cdf6de5c
Get alerted when CVE-2023-0374 or the next vulnerability affects your stack