What’s Vulnerable › Vulnerabilities
CVE-2023-0377: Scriptless Social Sharing < 3.2.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Scriptless Social Sharing WordPress plugin before 3.2.2 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Scriptless Social Sharing: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Scriptless Social Sharing 3.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5b1aacd1-3f75-4a6f-8146-cbb98a713724
- https://wpscan.com/vulnerability/5b1aacd1-3f75-4a6f-8146-cbb98a713724
Get alerted when CVE-2023-0377 or the next vulnerability affects your stack