What’s Vulnerable › Vulnerabilities
CVE-2023-0379: Spotlight Social Feeds < 1.4.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Spotlight Social Feeds WordPress plugin before 1.4.3 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Spotlight Social Feeds [Block, Shortcode, and Widget]: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: Spotlight Social Feeds [Block, Shortcode, and Widget] 1.4.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14b4f0c5-c7b1-4ac4-8c9c-f8c35ca5de4a
- https://wpscan.com/vulnerability/14b4f0c5-c7b1-4ac4-8c9c-f8c35ca5de4a
Get alerted when CVE-2023-0379 or the next vulnerability affects your stack