What’s Vulnerable › Vulnerabilities
CVE-2023-0385: Custom 404 Pro <= 3.7.1 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The Custom 404 Pro plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.7.1. This is due to missing or incorrect nonce validation on the custom_404_pro_admin_init function. This makes it possible for unauthenticated attackers to delete logs, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Kunal Nagar Custom 404 Pro: before 3.7.2 — fixed in 3.7.2
How to fix
Upgrade to a fixed version: Kunal Nagar Custom 404 Pro 3.7.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/custom-404-pro/tags/3.7.1/admin/AdminClass.php#L114
- https://www.wordfence.com/threat-intel/vulnerabilities/id/968920b9-febf-4d76-a16b-f27954cd72e5?source=cve
- https://plugins.trac.wordpress.org/browser/custom-404-pro/tags/3.7.1/admin/AdminClass.php#L114
- https://www.wordfence.com/threat-intel/vulnerabilities/id/968920b9-febf-4d76-a16b-f27954cd72e5
Get alerted when CVE-2023-0385 or the next vulnerability affects your stack