What’s Vulnerable › Vulnerabilities
CVE-2023-0403: Social Warfare <= 4.3.1 - Cross-Site Request Forgery
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-352
Description
The Social Warfare plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.3.1. This is due to missing or incorrect nonce validation on several AJAX actions. This makes it possible for unauthenticated attackers to delete post meta information and reset network access tokens, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- warfareplugins Social Sharing Plugin – Social Warfare: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: warfareplugins Social Sharing Plugin – Social Warfare 4.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/social-warfare/trunk/lib/options/SWP_Options_Page.php?rev=2364155#L923
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a36d1bb1-9446-4042-a1ec-08a3ffdcb744?source=cve
- https://plugins.trac.wordpress.org/browser/social-warfare/trunk/lib/options/SWP_Options_Page.php?rev=2364155#L923
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a36d1bb1-9446-4042-a1ec-08a3ffdcb744
Get alerted when CVE-2023-0403 or the next vulnerability affects your stack