What’s Vulnerable › Vulnerabilities
CVE-2023-0410: Cross-site Scripting (XSS) - Generic in builderio/qwik
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in GitHub repository builderio/qwik prior to 0.1.0-beta5.
Affected products
- QwikDev qwik: before 0.16.2 — fixed in 0.16.2
How to fix
Upgrade to a fixed version: QwikDev qwik 0.16.2. Check the vendor advisory for mitigations.
References
- https://github.com/builderio/qwik/commit/4b2f89dbbd2bc0a2c92eae1a49bdd186e589151a
- https://huntr.dev/bounties/2da583f0-7f66-4ba7-9bed-8e7229aa578e
- https://github.com/builderio/qwik/commit/4b2f89dbbd2bc0a2c92eae1a49bdd186e589151a
- https://huntr.dev/bounties/2da583f0-7f66-4ba7-9bed-8e7229aa578e
Get alerted when CVE-2023-0410 or the next vulnerability affects your stack