What’s Vulnerable › Vulnerabilities
CVE-2023-0419: Shortcode for Font Awesome < 1.4.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Shortcode for Font Awesome WordPress plugin before 1.4.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedded, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Shortcode for Font Awesome: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Shortcode for Font Awesome 1.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5ccfee43-920d-4613-b976-2ea8966696ba
- https://wpscan.com/vulnerability/5ccfee43-920d-4613-b976-2ea8966696ba
Get alerted when CVE-2023-0419 or the next vulnerability affects your stack