What’s Vulnerable › Vulnerabilities
CVE-2023-0423: WordPress Amazon S3 Plugin < 1.6 - Reflected XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
Description
The WordPress Amazon S3 Plugin WordPress plugin before 1.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- WordPress Amazon S3 Plugin: before 1.6 — fixed in 1.6
How to fix
Upgrade to a fixed version: WordPress Amazon S3 Plugin 1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/73d588d7-26ae-42e2-8282-aa02bcb109b6
- https://wpscan.com/vulnerability/73d588d7-26ae-42e2-8282-aa02bcb109b6
Get alerted when CVE-2023-0423 or the next vulnerability affects your stack