What’s Vulnerable › Vulnerabilities
CVE-2023-0442: Loan Comparison < 1.5.2 - Reflected XSS via shortcode
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The Loan Comparison WordPress plugin before 1.5.3 does not validate and escape some of its query parameters before outputting them back in a page/post via an embedded shortcode, which could allow an attacker to inject javascript into into the site via a crafted URL.
Affected products
- Loan Comparison Project Loan Comparison: before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: Loan Comparison Project Loan Comparison 1.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/34d95d88-4114-4597-b4db-e9f5ef80d322
- https://wpscan.com/vulnerability/34d95d88-4114-4597-b4db-e9f5ef80d322
Get alerted when CVE-2023-0442 or the next vulnerability affects your stack