What’s Vulnerable › Vulnerabilities
CVE-2023-0450
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
Description
An issue has been discovered in GitLab affecting all versions starting from 8.1 to 15.8.5, and from 15.9 to 15.9.4, and from 15.10 to 15.10.1. It was possible to add a branch with an ambiguous name that could be used to social engineer users.
Affected products
- GitLab: from 8.1.0 before 15.8.5; from 15.9.0 before 15.9.4; 15.10.0 — fixed in 15.8.5, 15.9.4
How to fix
Upgrade to a fixed version: GitLab 15.8.5, 15.9.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-0450.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/388962
- https://hackerone.com/reports/1831547
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-0450.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/388962
- https://hackerone.com/reports/1831547
Get alerted when CVE-2023-0450 or the next vulnerability affects your stack