What’s Vulnerable › Vulnerabilities
CVE-2023-0456: Apicast proxies the api call with incorrect jwt token to the api backend without proper authorization check
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-285
Description
A flaw was found in APICast, when 3Scale's OIDC module does not properly evaluate the response to a mismatched token from a separate realm. This could allow a separate realm to be accessible to an attacker, permitting access to unauthorized information.
Affected products
- apicast: before 2.12.2; from 2.13.0 before 2.13.2 — fixed in 2.12.2, 2.13.2
How to fix
Upgrade to a fixed version: apicast 2.12.2, 2.13.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-0456
- https://bugzilla.redhat.com/show_bug.cgi?id=2163586
- https://access.redhat.com/security/cve/CVE-2023-0456
- https://bugzilla.redhat.com/show_bug.cgi?id=2163586
Get alerted when CVE-2023-0456 or the next vulnerability affects your stack