What’s Vulnerable › Vulnerabilities
CVE-2023-0458: Spectre V1 Gadget in do_prlimit in the Linux Kernel
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-26 · updated 2026-06-17
- Weakness: CWE-476
Description
A speculative pointer dereference problem exists in the Linux Kernel on the do_prlimit() function. The resource argument value is controlled and is used in pointer arithmetic for the 'rlim' variable and can be used to leak the contents. We recommend upgrading past version 6.1.8 or commit 739790605705ddcf18f21782b9c99ad7d53a8c11
Affected products
- Debian Linux: 10.0
- Linux kernel: before 6.1.8; 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4 — fixed in 6.1.8
How to fix
Upgrade to a fixed version: Linux kernel 6.1.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/kernel/sys.c?id=v6.1.8&id2=v6.1.7
- https://github.com/torvalds/linux/commit/739790605705ddcf18f21782b9c99ad7d53a8c11
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/kernel/sys.c?id=v6.1.8&id2=v6.1.7
- https://github.com/torvalds/linux/commit/739790605705ddcf18f21782b9c99ad7d53a8c11
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
Get alerted when CVE-2023-0458 or the next vulnerability affects your stack