What’s Vulnerable › Vulnerabilities
CVE-2023-0479: Print Invoice & Delivery Notes for WooCommerce < 4.7.2 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Print Invoice & Delivery Notes for WooCommerce WordPress plugin before 4.7.2 is vulnerable to reflected XSS by echoing a GET value in an admin note within the WooCommerce orders page. This means that this vulnerability can be exploited for users with the edit_others_shop_orders capability. WooCommerce must be installed and active. This vulnerability is caused by a urldecode() after cleanup with esc_url_raw(), allowing double encoding.
Affected products
- tychesoftwares Print Invoice & Delivery Notes for WooCommerce: before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: tychesoftwares Print Invoice & Delivery Notes for WooCommerce 4.7.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/50963747-ae8e-42b4-bb42-cc848be7b92e/
- https://wpscan.com/vulnerability/50963747-ae8e-42b4-bb42-cc848be7b92e/
Get alerted when CVE-2023-0479 or the next vulnerability affects your stack