What’s Vulnerable › Vulnerabilities
CVE-2023-0488: Cross-site Scripting (XSS) - Stored in pyload/pyload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pyload/pyload prior to 0.5.0b3.dev42.
Affected products
- pyload/pyload: before 2023-01-24 — fixed in 2023-01-24
- pyload: before 0.5.0b3.dev42 — fixed in 0.5.0b3.dev42
How to fix
Upgrade to a fixed version: pyload/pyload 2023-01-24; pyload 0.5.0b3.dev42. Check the vendor advisory for mitigations.
References
- https://github.com/pyload/pyload/commit/46d75a3087f3237d06530d55998938e2e2bda6bd
- https://huntr.dev/bounties/4311d8d7-682c-4f2a-b92c-3f9f1a36255a
- https://github.com/pyload/pyload/commit/46d75a3087f3237d06530d55998938e2e2bda6bd
- https://huntr.dev/bounties/4311d8d7-682c-4f2a-b92c-3f9f1a36255a
Get alerted when CVE-2023-0488 or the next vulnerability affects your stack