What’s Vulnerable › Vulnerabilities
CVE-2023-0492: GS Products Slider for WooCommerce < 1.5.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The GS Products Slider for WooCommerce WordPress plugin before 1.5.9 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- GS Products Slider for WooCommerce: before 1.5.9 — fixed in 1.5.9
How to fix
Upgrade to a fixed version: GS Products Slider for WooCommerce 1.5.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ea3b129d-32d8-40e3-b1af-8b92a760db23
- https://wpscan.com/vulnerability/ea3b129d-32d8-40e3-b1af-8b92a760db23
Get alerted when CVE-2023-0492 or the next vulnerability affects your stack