What’s Vulnerable › Vulnerabilities
CVE-2023-0493: Improper Neutralization of Equivalent Special Elements in btcpayserver/btcpayserver
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-76
Description
Improper Neutralization of Equivalent Special Elements in GitHub repository btcpayserver/btcpayserver prior to 1.7.5.
Affected products
- btcpayserver/btcpayserver: before 1.7.5 — fixed in 1.7.5
How to fix
Upgrade to a fixed version: btcpayserver/btcpayserver 1.7.5. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171732/BTCPay-Server-1.7.4-HTML-Injection.html
- https://github.com/btcpayserver/btcpayserver/pull/4545/commits/02070d65836cd24627929b3403efbae8de56039a
- https://huntr.dev/bounties/3a73b45c-6f3e-4536-a327-cdfdbc59896f
- http://packetstormsecurity.com/files/171732/BTCPay-Server-1.7.4-HTML-Injection.html
- https://github.com/btcpayserver/btcpayserver/pull/4545/commits/02070d65836cd24627929b3403efbae8de56039a
- https://huntr.dev/bounties/3a73b45c-6f3e-4536-a327-cdfdbc59896f
Get alerted when CVE-2023-0493 or the next vulnerability affects your stack