What’s Vulnerable › Vulnerabilities
CVE-2023-0509: Improper Certificate Validation in pyload/pyload
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper Certificate Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev44.
Affected products
- pyload/pyload: before 2023-01-25 — fixed in 2023-01-25
- pyload: before 0.5.0b3.dev44 — fixed in 0.5.0b3.dev44
How to fix
Upgrade to a fixed version: pyload/pyload 2023-01-25; pyload 0.5.0b3.dev44. Check the vendor advisory for mitigations.
References
- https://github.com/pyload/pyload/commit/a9098bdf7406e6faf9df3da6ff2d584e90c13bbb
- https://huntr.dev/bounties/a370e0c2-a41c-4871-ad91-bc6f31a8e839
- https://github.com/pyload/pyload/commit/a9098bdf7406e6faf9df3da6ff2d584e90c13bbb
- https://huntr.dev/bounties/a370e0c2-a41c-4871-ad91-bc6f31a8e839
Get alerted when CVE-2023-0509 or the next vulnerability affects your stack