What’s Vulnerable › Vulnerabilities
CVE-2023-0540: GS Filterable Portfolio < 1.6.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The GS Filterable Portfolio WordPress plugin before 1.6.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- GS Filterable Portfolio: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: GS Filterable Portfolio 1.6.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b35b3da2-468d-4fe5-bff6-812432197a38
- https://wpscan.com/vulnerability/b35b3da2-468d-4fe5-bff6-812432197a38
Get alerted when CVE-2023-0540 or the next vulnerability affects your stack