What’s Vulnerable › Vulnerabilities
CVE-2023-0541: GS Books Showcase < 1.3.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
Description
The GS Books Showcase WordPress plugin before 1.3.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- GS Books Showcase: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: GS Books Showcase 1.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8453e587-cc8c-491a-af09-fc4ab215134b
- https://wpscan.com/vulnerability/8453e587-cc8c-491a-af09-fc4ab215134b
Get alerted when CVE-2023-0541 or the next vulnerability affects your stack