What’s Vulnerable › Vulnerabilities
CVE-2023-0546: FluentForms < 4.3.25 - Contributor+ Stored XSS via Custom HTML Form Field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
Description
The Contact Form Plugin WordPress plugin before 4.3.25 does not properly sanitize and escape the srcdoc attribute in iframes in it's custom HTML field type, allowing a logged in user with roles as low as contributor to inject arbitrary javascript into a form which will trigger for any visitor to the form or admins previewing or editing the form.
Affected products
- techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder: before 4.3.25 — fixed in 4.3.25
How to fix
Upgrade to a fixed version: techjewel Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder 4.3.25. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/078f33cd-0f5c-46fe-b858-2107a09c6b69
- https://wpscan.com/vulnerability/078f33cd-0f5c-46fe-b858-2107a09c6b69
Get alerted when CVE-2023-0546 or the next vulnerability affects your stack