What’s Vulnerable › Vulnerabilities
CVE-2023-0557: ContentStudio <= 1.2.5 - Information Exposure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-200
Description
The ContentStudio plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 1.2.5. This could allow unauthenticated attackers to obtain a nonce needed for the creation of posts.
Affected products
- ContentStudio: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: ContentStudio 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/contentstudio/trunk/contentstudio-plugin.php#L709
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2851006%40contentstudio%2Ftrunk&old=2844028%40contentstudio%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62eb136f-3cb0-40dc-a154-015a7fa1077b?source=cve
- https://plugins.trac.wordpress.org/browser/contentstudio/trunk/contentstudio-plugin.php#L709
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2851006%40contentstudio%2Ftrunk&old=2844028%40contentstudio%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62eb136f-3cb0-40dc-a154-015a7fa1077b
Get alerted when CVE-2023-0557 or the next vulnerability affects your stack