What’s Vulnerable › Vulnerabilities
CVE-2023-0558: ContentStudio <= 1.2.5 - Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-639
Description
The ContentStudio plugin for WordPress is vulnerable to authorization bypass due to an unsecure token check that is susceptible to type juggling in versions up to, and including, 1.2.5. This makes it possible for unauthenticated attackers to execute functions intended for use by users with proper API keys.
Affected products
- ContentStudio: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: ContentStudio 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/contentstudio/trunk/contentstudio-plugin.php#L416
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c31828dc-ef94-4895-8395-a5d52a0a82bd?source=cve
- https://plugins.trac.wordpress.org/browser/contentstudio/trunk/contentstudio-plugin.php#L416
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c31828dc-ef94-4895-8395-a5d52a0a82bd?source=cve
Get alerted when CVE-2023-0558 or the next vulnerability affects your stack