What’s Vulnerable › Vulnerabilities
CVE-2023-0568: Array overrun in common path resolve code
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-131
Description
In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, core path resolution function allocate buffer one byte too small. When resolving paths with lengths close to system MAXPATHLEN setting, this may lead to the byte after the allocated buffer being overwritten with NUL value, which might lead to unauthorized data access or modification.
Affected products
- PHP: from 8.0.0 before 8.0.28; from 8.1.0 before 8.1.16; from 8.2.0 before 8.2.3 — fixed in 8.0.28, 8.1.16, 8.2.3
How to fix
Upgrade to a fixed version: PHP 8.0.28, 8.1.16, 8.2.3. Check the vendor advisory for mitigations.
References
- https://bugs.php.net/bug.php?id=81746
- https://security.netapp.com/advisory/ntap-20230517-0001/
- https://bugs.php.net/bug.php?id=81746
- https://security.netapp.com/advisory/ntap-20230517-0001/
Get alerted when CVE-2023-0568 or the next vulnerability affects your stack