What’s Vulnerable › Vulnerabilities
CVE-2023-0579: YARPP - Yet Another Related Posts Plugin < 5.30.3 - Subscriber+ SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-89
Description
The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before using them in SQL statement/s, which could allow any authenticated users, such as subscribers to perform SQL Injection attacks.
Affected products
- jeffparker YARPP – Yet Another Related Posts Plugin: before 5.30.3 — fixed in 5.30.3
How to fix
Upgrade to a fixed version: jeffparker YARPP – Yet Another Related Posts Plugin 5.30.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/574f7607-96d8-4ef8-b96c-0425ad7e7690
- https://wpscan.com/vulnerability/574f7607-96d8-4ef8-b96c-0425ad7e7690
Get alerted when CVE-2023-0579 or the next vulnerability affects your stack