What’s Vulnerable › Vulnerabilities
CVE-2023-0581: PrivateContent <= 8.4.3 - Protection Mechanism Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-602
Description
The PrivateContent plugin for WordPress is vulnerable to protection mechanism bypass due to the use of client side validation in versions up to, and including, 8.4.3. This is due to the plugin checking if an IP had been blocklist via client-side scripts rather than server-side. This makes it possible for unauthenticated attackers to bypass any login restrictions that may prevent a brute force attack.
Affected products
- LCweb PrivateContent: before 8.4.4 — fixed in 8.4.4
How to fix
Upgrade to a fixed version: LCweb PrivateContent 8.4.4. Check the vendor advisory for mitigations.
References
- https://lcweb.it/privatecontent/changelog
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de73304e-7a28-4304-b1ed-2f6dd7738236?source=cve
- https://lcweb.it/privatecontent/changelog
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de73304e-7a28-4304-b1ed-2f6dd7738236
Get alerted when CVE-2023-0581 or the next vulnerability affects your stack