What’s Vulnerable › Vulnerabilities
CVE-2023-0614
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-03 · updated 2026-06-17
- Weakness: CWE-200
Description
The fix in 4.6.16, 4.7.9, 4.8.4 and 4.9.7 for CVE-2018-10919 Confidential attribute disclosure vi LDAP filters was insufficient and an attacker may be able to obtain confidential BitLocker recovery keys from a Samba AD DC.
Affected products
- Samba: from 4.0.0 before 4.16.10; from 4.17.0 before 4.17.7; 4.18.0, 4.18.0-rc1, 4.18.0-rc2, 4.18.0-rc3, 4.18.0-rc4 — fixed in 4.16.10, 4.17.7
How to fix
Upgrade to a fixed version: Samba 4.16.10, 4.17.7. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YXBPYIA4VWNOD437NAHZ3NXKAETLFB5S/
- https://security.gentoo.org/glsa/202309-06
- https://security.netapp.com/advisory/ntap-20230406-0007/
- https://www.samba.org/samba/security/CVE-2023-0614.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YXBPYIA4VWNOD437NAHZ3NXKAETLFB5S/
- https://security.gentoo.org/glsa/202309-06
- https://security.netapp.com/advisory/ntap-20230406-0007/
- https://www.samba.org/samba/security/CVE-2023-0614.html
Get alerted when CVE-2023-0614 or the next vulnerability affects your stack