What’s Vulnerable › Vulnerabilities
CVE-2023-0625: Docker Desktop before 4.12.0 is vulnerable to RCE via a crafted extension description or changelog
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Docker Desktop before 4.12.0 is vulnerable to RCE via a crafted extension description or changelog. This issue affects Docker Desktop: before 4.12.0.
Affected products
- Docker Inc. Docker Desktop: before 4.12.0 — fixed in 4.12.0
How to fix
Upgrade to a fixed version: Docker Inc. Docker Desktop 4.12.0. Check the vendor advisory for mitigations.
References
- https://docs.docker.com/desktop/release-notes/#4120
- https://docs.docker.com/desktop/release-notes/#4120
Get alerted when CVE-2023-0625 or the next vulnerability affects your stack