What’s Vulnerable › Vulnerabilities
CVE-2023-0667: Wireshark MSMMS parsing buffer overflow
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-122
Description
Due to failure in validating the length provided by an attacker-crafted MSMMS packet, Wireshark version 4.0.5 and prior, in an unusual configuration, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark
Affected products
- Wireshark Foundation Wireshark: from 4.0.0 before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.0.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/issues/19086
- https://security.gentoo.org/glsa/202309-02
- https://takeonme.org/cves/CVE-2023-0667.html
- https://gitlab.com/wireshark/wireshark/-/issues/19086
- https://lists.debian.org/debian-lts-announce/2024/09/msg00049.html
- https://security.gentoo.org/glsa/202309-02
- https://takeonme.org/cves/CVE-2023-0667.html
Get alerted when CVE-2023-0667 or the next vulnerability affects your stack